Web forms on Skidmore website not functioning

Resolved
Operational
Started 7 months ago Lasted about 6 hours

Affected

Skidmore Website
Updates
  • Resolved
    Resolved

    This incident has been resolved.

  • Investigating
    Investigating

    OCM and IT are investigating a time-out issue with skidmore.edu form submissions. Please do not submit any forms through the skidmore.edu website as they will not be fully processed. Any questions, feel free to reach out to the Web Team at webteam@skidmore.edu. Please continue to check back here for updates. Thank you for your patience and understanding.