Card system down

Resolved
Operational
Started over 1 year ago Lasted about 6 hours

Affected

Network
Card system
Updates
  • Resolved
    Resolved

    We just resolved the issue!

  • Monitoring
    Monitoring

    We hope to have the system back up and running by about 3pm today.

  • Identified
    Identified

    We are continuing to work on a fix for this incident.