Skidmore College - Box.com access is down – Incident details

Box.com access is down

Resolved
Major outage
Started over 2 years agoLasted 1 day

Affected

Box.com

Major outage from 1:14 PM to 7:46 PM

Updates
  • Resolved
    Resolved

    We just resolved the issue!

  • Identified
    Identified

    We have identified the issue Skidmore folks are having with accessing Box.com and we are working with the folks at Box.com to resolve the issue. We will update our Status page with an ETA for this fix as soon as we have one.

  • Investigating
    Investigating

    We are currently investigating this incident.